PHP compatibility

Open
S Support February 22, 2019
Login to reply
Paul Cartwright
11 months ago

  Hello chaps.

Just upgraded Wordpress to 5.1 and run the PHP Compatibility Checker plugin as my site PHP is 5.4.

The results came up with this:

FILE: /home4/pcbrand/public_html/wp-content/plugins/marshmallow_pryanik_widgets/pryanik-widgets.php

---------------------------------------------------------------------------------------------------

FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES

---------------------------------------------------------------------------------------------------

 384 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.

 594 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.

---------------------------------------------------------------------------------------------------

Is this something you can fix/amend? Presumably if Wordpress are advising everyone to check their PHP versions you may be getting other requests?

Many thanks.


Paul

Additional Info

ThemeForest Item: Marshmallow WordPress theme